El día de ayer (27 de Julio del 2010) sucedió unas de las cosas más terroríficas que un desarrollador de realidad aumentada le puede suceder: Tengo problemas con la Webcam!!!!!!!

A modo de introducción un poco exagerada 😛 les quiero contar lo que me sucedio y que gracias a eso hice nuevos experimentos junto a mi amigo Alfonso Moreno.

Ayer en la mañana descargué una librería de processing llamada Voltron que es “especialista” en shapes 3D. Esa librería pesada para trabajar con processing 1.2.1 dejó algún rastro maligno en mi computadora.

En la tarde quise avanzar algunas cosas de realidad aumentada y !oh sorpresa! no detectaba mi cámara y ni siquiera la instalación de Quicktime. Reinicié pensando que era algún error del momento y no fue así.

Intenté instalar todo de nuevo (Quicktime y  WinVDIG) para solucionar el problema. Busqué e instalé casi todas las versiones existentes de Quicktime y probé cada una de las 4 versiones de WinVDIG.

Realicé una prueba de ensayo y error. Algunas combinaciones lograban funcionar pero otras no y cuando lo hacía la cámara web aparecía con un color muy raro.

El día de hoy insistí para encontrar la solución. Conversando como Alfonso Moreno me comentó que también le pasó algo similar. Él es un usuario de Mac y aunque no usa windvig, la librería Voltron le pedía un archivo jar y luego no le permitió usar sus trabajos de realidad aumentada.

Decidí probar todos los pasos que yo hice para instalar quicktime con WinVDIG en otra computadora y funcionó!

Mi cámara web probada en otros servicios como msn comenzaba a tener algunos problemas parecidos. Por lo que supuse que es mi cámara web la que está fallando.

Por el momento no podré hacer ningun ejemplo de realidad aumentada, así que me compraré otra cámara web esperando encontrar la solución!

Actualización:

Luego de borrar por completo Quicktime y WinVDIG del sistema. Además usé Ccleaner para eliminar el registro de los archivos.
Instalé el Quicktime 7.6.6 con el WinVDIG 1.0.1

Antes de finalizar la instalación de Quicktime, aparece una opcion sobre modificar archivos tipo Mime y le dí a check a todas las opciones de video.

Les dejo los link que revisé en busca de mi solución:

  • http://visualp5.net/tutoriales/index.php?title=Usuario:Instalacion#Windows
  • http://wiki.processing.org/w/Video_Issues
  • http://processing.org/discourse/yabb2/YaBB.pl?num=1243218553
  • http://processing.org/discourse/yabb2/YaBB.pl?num=1272859571
  • http://processing.org/discourse/yabb/YaBB.cgi?board=Proce55ing_software_bugs;action=display;num=1085150136
  • http://foro.visualp5.net/index.php?topic=364.0

Actualización (8/8/10)

Malogré de nuevo el setting de la cámara 😛 y salía este mensaje

UnsatisfiedLinkError: quicktime.QTSession.InitializeQTML(I)S

Miré el QTcap y vi que si funcionaba correctamente. Lo que hize es instalar de nuevo Quicktime y le dí la opción reparar. Y funcionó! 😀

Nueva actualización (23/07/12)

Ahora tengo windows 7 y la verdad he tenido problemas en instalar de nuevo el dichoso programa. A mi me funcionó con la versión 09.

1 COMMENT

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.